Eğer (IF) Fonksiyonu


Excel’de en çok karsımıza çikacak fonksiyonlardan bir tanesi EĞER (IF) fonksiyonudur.

Belirli şartlar sağlanırsa yapılacak işlemler sağlanmazsa yapılacak işlemleri konsolide şekilde tek bir formülle yazmamızı sağlar.

EĞER(mantıksal_sınama, eğer_doğruysa_değer, [eğer_yanlışsa_değer])

IF(logical_test, value_if_true, [value_if_false])

Basit olarak:

=Eğer(aranan koşul; koşul sağlanırsa değer; sağlanmazsa değer) şeklinde özetlenebilir.

ifeger
Puan 40’dan büyükse geçti, değilse kaldı.

EĞER/IF ve VE/AND Kullanımı:

Birden fazla koşulun gerçekleşmesi durumunda yaptırmak istediğimiz işlemler için EĞER/IF ile birlikte VE/AND fonksiyonu kullanılır.

Örneğin yukarıdaki örneğimize bir de vizeden min. 40 puan alma şartı ekleyelim. Vize ve Finalden 40 üzeri alanlar geçti, diğerleri kaldı. VE/AND fonksiyonu şartların ikisini de kontrol eder ve ikisinin de sağlandığı durumlarda “TRUE” değerini döndürür. (yani Koşul sağlanmış kabul eder)

ifand
Vizeden ve finalden alınan puanın her ikisi de 40’dan büyükse geçti, değilse kaldı

EĞER/IF ve YADA/OR Kullanımı:

Bu sefer yine aynı örneği YADA/OR kullanarak yapalım. Vize yada finalden 40’ın üzerinden alan geçer.

YADA/OR fonksiyonu şartları en az biri sağlanıyorsa “TRUE” değerini döndürür. (yani Koşul sağlanmış kabul eder)

ifor
Vizeden veya finalden alınan puanın en az bir tanesi 40’dan büyükse geçti, değilse kaldı.

EĞER/IF VE/AND ve YADA/OR beraber kullanımı:

Bir arkadaşımızın sorduğu bir soru vardı önceki yazılardan o soruyu da bu başlık altında çözelim

bir işletme için 3 veri var:

A (değeri C2 de yazılı),
B (değeri C3 de yazılı),
C (değeri C4 de yazılı).

bu işletmenin X olması için
A nın 250 den küçük oması lazım.
aynı zamanda B ve C den en az birinin de 40 dan büyük olmaması lazım.

=EĞER(VE(C2<250;C3<40);”X”;”X DEĞİL”)
gibi bi formül yazdım ama C4 sınamasını yaptıramadım. Bunu nasıl çözebilirim.

iforand

iforandeger

Formülü okuyalım:

1.kesin koşul A <250 olmalı

2.kesin koşul B ve ya C 40’dan büyük olmamalı. B ve C arasında bir ve ya koşulu söz konusu.

  1. ve 2. koşulların ise her ikisininde sağlanması gerekiyor yani bir AND söz konusu.

Tüm koşulları tek bir formülde yazarsak

=IF(AND(A<250;OR(B<40;C<40));”X”;”X değil”)

=EĞER(VE(A<250;YADA(B<40;C<40));”X”;”X değil”)

Excel dosyasını indirmek için tıklayınız:

if_eger_fonksiyonu

 

Reklamlar

Eğer (IF) Fonksiyonu” üzerine 7 yorum

  1. merhabalar;
    bir hücrenin değeri 100 den küçükse; 100 ile 400 arasında ve 400 den büyükse değerlerinin her biri için ayrı çarpanı nasıl formülize ederiz.

    • Deger iceren hucre A1 hucresi olsun. Formul = IF(A1>400,”400’den buyuk”,IF(A1>=100,”100-400 arasi”,”100’den kucuk”)

  2. =EĞER(G2=”B”; “-“;”+”) böyle bi formül yazdım fakat – ya da + olacak değeri nasıl yazacağım yani şöyle bir sutunda sayılarım var diğerinde B/A var B olanlar – olacak A olanlar + ve bunu sayının başına eklemem gerekiyor 1900 tane satır var tek tek yapamam var mı bi çözümü??

Bir Cevap Yazın

Aşağıya bilgilerinizi girin veya oturum açmak için bir simgeye tıklayın:

WordPress.com Logosu

WordPress.com hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Google+ fotoğrafı

Google+ hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Twitter resmi

Twitter hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Facebook fotoğrafı

Facebook hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Connecting to %s