Topla.Çarpım (SumProduct) Fonksiyonu


Topla.Çarpım verilen dizilerdeki karşılıklı degerleri çarpar ve toplamını verir yani iki veya daha fazla satırdaki verileri karşılıklı çarpıp toplamının sonucunu verir.

TOPLA.ÇARPIM(dizi1, [dizi2], [dizi3], …)

SUMPRDODUCT(array1,[array2],[array3]..)

Bir çok hesaplamada işimize yarayacak topla.çarpım fonksiyonu değişik örneklerle inceleyelim:

 

1- İlk örnekte farklı kilo ve fiyatlarda ürün aldığımızı varsayalım ve toplam ödenen rakamı tek bir fonksiyonla çözelim:

 4
 2-Şimdi işi biraz daha detaylandıralım bir ve ya daha fazla verinin yer aldığı sütunlardaki istediğimiz türlerin ya da grupların alt toplamlarını bulalım.
 sumproduct
sumproduct2

3- İki değişkenli düşeyarayı topla çarpım ile çözelim. Burada iki farklı kişinin aldığı ürünler verilmiş aşağıdaki iki satırlı tabloya alinin aldığı elma toplamı ikinci satıra ise yine Ali’nin aldığı armut miktarı toplamını bulalım.

sumproduct3

sumproduct4

=SUMPRODUCT((A13=$A$2:$A$9)*(B13=$B$2:$B$9)*($C$2:$C$9))

=TOPLA.ÇARPIM((A13=$A$2:$A$9)*(B13=$B$2:$B$9)*($C$2:$C$9))
A13 yani “Ali” ismini A2:A9 aralığında ara, B13 yani “elma” ismini B2:B9 aralığında ara iki veriyi de aynı satırda bulduğunda bu satıra karşılık gelen C sütunundaki miktarları al, ve toplayarak ilerle.

4-Son olarak topla çarpım ile koşullu sıralama yapalım. Aşağıdaki örnekte aynı bölge içerisinde olana satışçıların satış rakamlarını büyükten küçüğe doğru sıralayacağız.
sumproduct5
=TOPLA.ÇARPIM((B2=$B$2:$B$7)*(C2<$C$2:$C$7))+1
Aynı bölgeleri bul, bu bölgeler içerisinde satış adetlerini karşılaştır, ilgili hücrenin kendinden büyük olan hücre sayısını döndür.
NOT :+1 eklememizin sebebi en yüksek satış adediden daha büyük adet olmadığı için sonucu 0 sıfır döndürecek. ancak biz sıralamanın 1 den başlamasını istediğimiz için formülün sonuna +1 ekledik.
 excel dosyasını indirmek için tıklayınız:
download

Reklamlar

Topla.Çarpım (SumProduct) Fonksiyonu” üzerine bir yorum

Bir Cevap Yazın

Aşağıya bilgilerinizi girin veya oturum açmak için bir simgeye tıklayın:

WordPress.com Logosu

WordPress.com hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Google+ fotoğrafı

Google+ hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Twitter resmi

Twitter hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Facebook fotoğrafı

Facebook hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Connecting to %s