Düşeyara (Vlookup) Fonksiyonu


vlookup

DÜŞEYARA / VLOOKUP belirli bir veri datası içerisinde istediğimiz verilere karşılık gelen değerleri bulmamızı sağlar. Excelde en çok kullanılan fonksiyonlardan bir tanesidir.

=DÜŞEYARA(aranan_değer;tablo_dizisi;sütun_indis_sayısı;[aralık_bak])

=VLOOKUP(lookup_value;table_array;col_index_num;[range_lookup])

DÜŞEYARA(neyi_arıyorum; nerede_arıyorum; aranan değeri bulduktan sonra sağa doğru kaçıncı bilgiyi istiyorum; 0 (sıfır))

Aranan_değer: Belirli bir data içerisinde bilgilerine ulaşmak istediğim değer

Tablo_dizisiAranan değerimin olduğu tablo, tabloyu seçerken aranan değerimin olduğu sütundan seçmeye başlamalıyım.

Sütun_indis_sayısı: Tabloda aranan değerimi bulduktan sonra aranan değere ait hangi veriyi getirmek istiyorsam o verinin göreceli sütun sırası

[aralık_bak]: Aranan değerimle tam eşleşme istiyorsam sıfır 0, yakın eşleşme istiyorsam 1 girilmeli. Genelllikle tam eşleşme istenilir ve bu kısım sıfır girilir.

örnek1: Yukarıdaki kahve fiyatlarını aşağıdaki tablodan faydalanarak düşeyara ile getirelim.

vlookup

vlookup2

B2 formülü okuyalım:

=VLOOKUP(A2,$A$5:$B$12,2,0)

=DÜŞEYARA(A2,$A$5:$B$12,2,0)

Aranan_değer: A2 hücresi, Latte’yi arıyorum

Tablo_dizisi: Kahve menüsü, A5:A12 tablosu

Sütun_indis_sayısı: 2, Tabloda aranan değerimi Latte ismini bulduktan sonra kahve fiyatı tabloda 2. sütunda

[aralık_bak]: Aranan değerimle tam eşleşme istiyorsam sıfır(0), yakın eşleşme istiyorsam 1 yazmalıyım. Tam eşleşme istediğimiz için buraya sıfır(0) değeri girdik.

Dikkat: Tablomu $A$5:$B$12 dolar işareti (F4) ile sabitledim ki formülü aşağıya ve ya yana doğru çekerken tablom kaymasın.

Yani aynı sayfada veya aynı excel kitabında bulunan tabloları kullanıyorsam düşeyara sırasında tablomu F4’e basarak yani dolar işareti ile sabitlemem gerekir. Farklı excel kitabındaki bir tabloyu kullanıyorsam sabitlemeye gerek yoktur.

örnek 2: Kahve menüsünü ad tanımlama ile tanımlayalım ve aynı örneği yeniden yapalım. Tablo seçili iken formüller, ad tanımlama ya geldik ve tabloyu “kahveler” olarak isimlendirdik. Böylelikle F4 ile tablomu sabitlememe gerek kalmadı.

vlookup vlookup_define_name vlookup_define_name2

DÜŞEYARA / VLOOKUP Özellikleri :

  1. Düşeyara CASE SENSITIVE değildir, yani aranan değer büyük harf ya da küçük harf ile yazılması formülü etkilemez.

VLOOKUPCASE

2. Düşeyara tabloda yukarıdan aşağıya aramaya başlar. Aynı değer 2 defa geçiyorsa yukarıdan aşağıya doğru ilk bulduğu değeri getirir. Diğerine bakmaz.

VLOOKUP_firts_match

3. Aranan değerler aynı tip olmalıdır. Text ve number formatındaki iki aynı değeri eşleştirmez. Hata verir. Text i number a ya da number ı text e dönüştürmelisiniz.

vlookuptext

4. Düşeyara yaparken aranan değerin sağında kalan kısımlar getirilebilir, solunda kalan kısımlar için düşeyara kullanılmaz. Bunun yerine KAÇINCI (MATCH) ile İNDİS (INDEX) fonksiyonlarını kullanabiliriz.

5. Eğer aranan değer tabloda yok ise Düşeyara #YOK /#N/A hatası alır. Bu hata değeri yerine farklı bir şey yazdırmak istiyorsak IFERROR fonksiyonunu kullanabiliriz.

vlookup_na

vlookup_na2

=>Tabloda mevcut olmadığından dolayı hata değeri döndüren formüller çeşitli matematiksel işlemlerin yapılmasını da engeller. Hata getiren değer yerine ifferror formülü ile sıfır yazar isek toplama, çıkarma, ortalama gibi işlemleri de yapabiliriz.

vlookup_na3

vlookup_na4

6. Başlık sayısının oldukça fazla olduğu durumlarda sıralı bir düzen var ise Sütun_indis_sayısı hücreden verilebilir.

cok_sutun2

cok_sutun

2016-04-17 20_16_43-Microsoft Excel - duseyara_vlookup

excel dosyasını indirmek için tıklayınız:

download

Reklamlar

Düşeyara (Vlookup) Fonksiyonu” üzerine 2 yorum

Bir Cevap Yazın

Aşağıya bilgilerinizi girin veya oturum açmak için bir simgeye tıklayın:

WordPress.com Logosu

WordPress.com hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Google fotoğrafı

Google hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Twitter resmi

Twitter hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Facebook fotoğrafı

Facebook hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Connecting to %s