İş Günü Sayısı Hesaplama


Tarih ve Saat Fonksiyonları ile ilgili temel formülleri Tarih ve Saat Fonksiyonlarına Giriş konusunda görmüştük. Bu konuda iş günü sayısı hesaplama ve farklı bir örnek olarak “Cumartesi” günleri dahil iş günü sayısı hesaplamayı öğreneceğiz. Çünkü NETWORKDAYS/TAMİŞGÜNÜ formülü hesaplama yaparken cumartesi ve pazar günlerini otomatik olarak hariç tuttuğu için ikinci örnekte formüle biraz eklemeler yapmamız gerekecek.

Önce basit bir örnekle başlayalım ve formülün kullanımını hatırlayalım.

1.2014 yılı Mayıs ayındaki iş günü sayısını hesaplayalım.

is_gunu

Formüldeki önemli kısımlar:

“B3” Yukarıda ay sonunu bulurken önceki ayın başından 1 gün geriye gittim.

“C5” Tatil olarak 1 Mayıs’ı girdim ve formülümün son kısmı olan üçüncü adımına yazdım.

2.2014 yılı Mayıs ayındaki iş günü sayısını Cumartesi günleri dahil hesaplayalım.

Şimdi mayıs ayı içerisindeki cumartesiler dahil iş günü sayısını bulmaya çalışalım, yukarıda cumartesiler hariç 21 gün olarak bulmuştuk, bunun üzerine cumartesi günlerinin sayısını ekleyeceğiz.

is_gunu

Öncelikle şöyle başlayalım bu bir dizi formülüdür ve formülü yazdıktan sonra ctrl + shift+enter a basmalıyız

Şimdi adım adım formülü okuyacağız:

{=SUM(COUNTIF(A9,WEEKDAY(DATE(2014,5,ROW(1:31)),2)))}

{=TOPLA(EĞERSAY(A9;HAFTANINGÜNÜ(TARİH(2014;5;SATIR(1:31));2)))}

A9: 6 – haftanın günlerinde cumartesi 6. sırada gelir. Mayıs ayı içerisinde 6 kaç defa geçmiş onu bulmak için buraya 6 girdik

HAFTANINGÜNÜ(TARİH(2014;5;SATIR(1:31));2) => işin dizi kısmı burası haftanın günlerini bul SATIR(1:31) 1 den ayın 31 ine kadarki ve bunları dizim içinde sakla, aslında arka planda bu fonksiyonun sonucu:

= {4,5,6,7,1,2,3,…..,5,6}=mayıs ayı perşembe ile başlıyor ve cmtesi ile bitiyor

Bu dizi içerisinde kaç defa 6 geçtiğini saydırdık. Ve topladık. sonucumuz 5 çıktı yani mayıs ayında toplamda 5 cumartesi var.

excel dosyasını indirmek için tıklayınız:

 

cumrtesi_dahil_isgunu_sayisi

Reklamlar

Bir Cevap Yazın

Aşağıya bilgilerinizi girin veya oturum açmak için bir simgeye tıklayın:

WordPress.com Logosu

WordPress.com hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Google+ fotoğrafı

Google+ hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Twitter resmi

Twitter hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Facebook fotoğrafı

Facebook hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Connecting to %s