Eğersay (Countif), Çokeğersay (Countifs)


Bu konuda eğersay ve çokeğersay fonksiyonları ve kullanımlarını inceleyeceğiz ve son bir örnekle konuyu pekiştirmeye çalışacağız:

EĞERSAY / COUNTIF fonksiyonu belirli bir hücre aralığındaki verilen koşula uyan hücre sayısını döndürür.

ÇOKEĞERSAY / COUNTIFS eğersay ile aynıdır tek fark  burada birden fazla koşulun gerçekleştiği hücre sayısı aranır.

EĞERSAY (aralık; ölçüt)

COUNTIF (range; criteria)

aralık (range) : koşulu aradığım hücre aralığı

ölçüt (criteria) : koşulum

ÇOKEĞERSAY (ölçüt_aralığı1;ölçüt1;ölçüt_aralığı2;ölçüt2)

COUNTIFS (criteria_range1; criteria1;criteria_range2; criteria2)

ölçüt_aralığı1 (criteria_range1) : koşulu aradığım hücre aralığı

ölçüt1 (criteria1) : ilk koşulum

ölçüt_aralığı2 (criteria_range2) : koşulu aradığım hücre aralığı

ölçüt2 (criteria2) : ikinci koşulum

örnek 1: öğrencileri yaş durumların göre analiz edelim:

Capture

COUNTIF

Dikkat: Eğersay fonksiyonlarında koşul verilirken çift tırnak içerisinde gösterilir.

METİN KARAKTER İÇEREN HÜCRE SAYISINI BULMA:

Eğersay fonksiyonunu metin karakter içeren hücre sayısı, belirli bir metin karakterle biten/başlayan hücre sayısını bulma gibi durumlarda da kullanılır. Hücrenin metin karakter içerip içermediği bulmak için koşul olarak  “*” sembolü girilir.

örnek 2:

CountIf_

VERI GIRISLERI DOGRU MU YAPILMIS?:

Şimdi karşımıza çıkabilecek güncel bir örnekle konuyu pekiştirelim. Diyelimki bir grup müşteriden sicil numarları yanınan TC kimlik numaralarını girmelerini istedik ve gelen listede girişlerin doğru yapılıp yapılmadığını kontrol etmek istiyoruz.

TC kimlik numarası:

  • 11 rakamdan oluşmalı,
  • ilk rakamı 3 ile başlamalı (bu koşulu biz uydurduk)
  • Metin karakter içermemeli (tamamı sayılardan olusmalı)

formul

tc_kontrol

=EĞER(VE(UZUNLUK(B2)=11;EĞERSAY(B2;”<>”&”*”)=1;SOLDAN(B2;1)=”3″);”ok”;”hatalı”)

=IF(AND(LEN(B2)=11,COUNTIF(B2,”<>”&”*”)=1,LEFT(B2,1)=”3″),”ok”,”hatalı”)

UZUNLUK(B2)=11  11 karakterden mi oluşuyor?

EĞERSAY(B2;”<>”&”*”)=1  ilgili hücrenin metin içermeyen hücre sayısı 1 olmalı.

SOLDAN(B2;1)=”3″  en baştaki rakam 3 ile başlamalı

excel dosyasını indirmek için tıklayınız: EGERSAY_COUNTIF

 

 

Reklamlar

Bir Cevap Yazın

Aşağıya bilgilerinizi girin veya oturum açmak için bir simgeye tıklayın:

WordPress.com Logosu

WordPress.com hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Google+ fotoğrafı

Google+ hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Twitter resmi

Twitter hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Facebook fotoğrafı

Facebook hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Connecting to %s