Hücreye Yinelenen Değerlerin Girilmesini Önleme


Veri Doğrulama (Data Validation) ile ilgili temel koşullar oluşturmayı veri doğrulamaya giriş konusunda görmüştük. Bundan sonraki bölümlerde veri doğrulama içerisinde formül yazarak data girişi nasıl kontrol edilir onu göreceğiz.

dataval

Aşağıdaki tabloya aynı sayının birden fazla girilmesini engelleyecek formülü veri doğrulama ile engelleyelim.

1.Tablomuz şeçili iken Menü’de Veri (Data) sekmesinden Veri Doğrulamayı (Data Validation) komutuna tıklayalım. Açılan pencerede Ayarlar/Settings sekmesi altında izin verilen (Allow) kısmı Özel (Custom) yaptık.

Capture

Microsoft Excel - veri_dogrulama_data_validation1

Data Validation

2.Formül (Formula) kısmına aşagıdaki formülümüzü girelim:

=COUNTIF($A$2:$A$12;A2)=1

=EĞERSAY($A$2:$A$12;A1) =1 koşulumuz bu aralıktaki her değerin bir defa bulunması.

Böylelikle çift veri girişini önlemiş olduk.

dataval

excel dosyasını indirmek için tıklayınız:

data_validation_yinelenen_deger_girilmesin

Reklamlar

Hücreye Yinelenen Değerlerin Girilmesini Önleme” üzerine 3 yorum

  1. Merhaba,

    Excelde farklı sütunlarda yinelenen değerler var ise belirlediğim sütunu boyasın istiyorum Örnek olarak aşağıdaki 2 satırdaki veriler de aynı olduğu için A sütununda yazan değeri boyamak istiyorum. Yapmak istediğim 1\’den fazla aynı girişleri tespit etmek

    A sütunu Bsütunu CSütunu DSütunu
    xxxxx 01.01.2018 X Değer 01.01.2018
    yyyyy 01.01.2018 X Değer 01.01.2018

Bir Cevap Yazın

Aşağıya bilgilerinizi girin veya oturum açmak için bir simgeye tıklayın:

WordPress.com Logosu

WordPress.com hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Google fotoğrafı

Google hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Twitter resmi

Twitter hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Facebook fotoğrafı

Facebook hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Connecting to %s