Hücre Aralığında Geçen Metin Sayısını Bulma


Bu örnekte bir hücre aralığında geçen bir kelimenin sayısını çeşitli şekillerde bulmaya çalışacağız.

liste

  • İçinde “elma” yazan hücre sayısı  =EĞERSAY(A2:A13;”elma”)

1

  • “elma” ile başlayıp ardından 3 karakter içeren hücre sayısı, her bir soru işareti 1 karakteri temsil ediyor. =EĞERSAY(A2:A13;”elma???”)

2

  • “elma” ile başlayan hücre sayısı =EĞERSAY(A2:A13;”elma*”)

3

  • Sağında ve solunda farklı karakterler içeren ya da içermeyen ancak içerisinde “elma” geçen hücre sayısı

=EĞERSAY(A2:A13;”*elma*”)

4

  • Metin içeren hücre sayısı =EĞERSAY(A2:A13;”*”)

5

excel dosyasını indirmek için tıklayınız:

download

Reklamlar

Hücre Aralığında Geçen Metin Sayısını Bulma” üzerine 6 yorum

  1. Merhabalar, kitap içerisindeki tüm sayfalarda D9:J9 aralığındaki değerleri nasıl saydırabilirim ? Teşekkürler.

  2. oncelikle muzazzam faydali bu platformda emegi gecenlere tesekkurler.
    elimizde 5 bin kisilik bir personel listesi var. bu excelde personelin tum ozellikleri yaziyor. yas,kilo,ayakkabi numarasi evlimi cocuklumu gibi tum bilgiler size sorum su olacak. A sutunundan BFsutununa kadar her sutunda bir data gurubu mevcut. T hucresinde yaslar yaziyor ornegin 35yasindakileri filitreledigimizde kalan personel sayisi 312, bu 312 kisinin en buyuk ortak ozelligini bulacak veya duger hucrelerdeki ortak paydalarin sayilarini bulabilecegimiz bir formul excelde mevcutmu ? ayni ornek uzerinden gidiyorum Tsutununda 35 yasindaki personeli filitreledigimizde sigara icen personel sayisi 43 veya ayakkabi numarasi 41 olan personel sayisi 54 gibi. fakat esas aradigim formul 35 yasindaki personelin en buyuk ortak ozelligini gosterecek bir formul varmidir ?

  3. hücre içerisinde uzun bir cümle olduğunu düşünelim. cümleyi oluşturan kelimelerin içerisinde mesela “a” harfi olan kelimeleri yan hücreye yazdırabilir miyiz

    • Eger bu tek bir cumle ise ornek olarak
      “Bildiğimiz üzere teknoloji tüm hızıyla gelişmeye devam ediyor. Dünya, teknolojinin gelişimine katkı sağlarken biz bireylerinde yapması gereken önemli görevler var”
      Oncelikle Veri sekmesi altindaki Text to column (Metni sutunlara donustur) komutu ile bosluklardan cumleyi ayirin.
      Tek bir satir boyunca her bir kelime bir sutuna yerlesecek sekilde geldi.
      Tumunu seçip kopyalayip transpose olarak yapistirin.
      Soyle bir gorunum olacak:

      Sonrasinda ise uygulayacaginiz formül asagidaki sekilde:
      =IF(ISERROR(FIND(“a”,A7,1)),””,A7)

  4. filtrelenmiş bir sütunda istediğim metini nası saydırabilirim? eğersay gibi olucak ama filtrelediğim zaman değişmesi lazım? Yardımınızı bekliyorum teşekkürler.

    • Filtrelenmis sutunda islem yapmak ve filtre her degistiginde islem sonucunun degismesini istiyorsak SUBTOTAL islevinden yaralanmaliyiz. Ancak SUBTOTAL da yapilabilecek hesaplamalar sinirlidir. Text iceren hucreleri COUNTA-COUNT hesaplamasiyla bulabiliriz. COUNTA = dolu hucrelerin sayisini COUNT= sayi iceren hucrelerin sayisini verir. Aradaki farkta metin iceren hucrelerin sayisini verecektir. Ancak spesifik bir metni ariyorsak SUBTOTAL islevi yeterli olmayacaktir. Bunun icin VBA kodu yazmamiz gerekir.
      SUBTOTAL konusuna asagidaki linkten ulasabilirsiniz.
      iyi calismalar
      https://excelyardim.wordpress.com/2015/08/26/alttoplam-subtotal-islevi-filtreli-degerlerle-hesaplama-yapmak/

Bir Cevap Yazın

Aşağıya bilgilerinizi girin veya oturum açmak için bir simgeye tıklayın:

WordPress.com Logosu

WordPress.com hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Google+ fotoğrafı

Google+ hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Twitter resmi

Twitter hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Facebook fotoğrafı

Facebook hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Connecting to %s