Her Satırdaki Min/Max Değerleri Renklendirme


Untitled

Bu bölümde formüller yardımıyla koşullu biçimlendirme nasıl yapılır örnek üzerinden anlatmaya çalışalım.

Elimizde aşağıdaki gibi bir hücre aralığı olsun ve her bir satırdaki max değeri mavi ile min değeri ise sarı ile gösterelim.

Microsoft Excel - conditional_formatting3

Tablo (A2:I9) seçili iken Home, Conditional Formating/Koşullu Biçimlendirme sekmesine gelelim. New Rule/Yeni kural komutunu tıklayalım, Biçimlendirilecek hücreleri belirlemek için formül kullan seçeneğine gelelim ve Bu formül doğru olduğunda değerleri biçimlendir ifadesinin altındakı formül çubuğuna yazılan formül doğru olursa renklendirme yapacak koşullu biçimlendirme formülünü yazalım.

Microsoft Excel - conditional_formatting4

DİKKAT : Formül yazarken en önemli püf nokta göreceli ve mutlak hücrelerin doğru belirlenmesi yani neleri dolar işaretiyle sabitleyeceğiz neleri sabitlemeyeceğiz.

Formül her bir hücreyi kendi satır aralığında tek tek kontrol edip o hücrenin o satır aralığının MAX değeri olup olmadığına bakıyor.

*Formül içerisinde kullanılan mutlak ve göreceli kavramları detaylı konu anlatımına buradan  ulaşabilirsiniz.

sonuç1:

Microsoft Excel - conditional_formatting5

Şimdi ayni formülü her bir satırdaki min değeri bulmak için yapalım.

Microsoft Excel - conditional_formatting6

sonuç2:

Microsoft Excel - conditional_formatting2

Tablo içerisindeki her bir hücreye random (rastgele) sayı üreten RANDBETWEEN/RASTGELEARADA formülünü girelim, F9 a basarak  sürekli yeni sayı üretelim, yazdığımız formül her seferinde min/max değerler için farklı hücreleri renklendiriyor olacak.

excel dosyasını indirmek icin tıklayınız:

download

 

Reklamlar

Her Satırdaki Min/Max Değerleri Renklendirme” üzerine 2 yorum

  1. bir işletme için 3 veri var:

    A (değeri C2 de yazılı),
    B (değeri C3 de yazılı),
    C (değeri C4 de yazılı).

    bu işletmenin X olması için
    A nın 250 den küçük oması lazım.
    aynı zamanda B ve C den en az birinin de 40 dan büyük olmaması lazım.

    =EĞER(VE(C2<250;C3<40);"X";"X DEĞİL")
    gibi bi formül yazdım ama C4 sınamasını yaptıramadım. Bunu nasıl çözebilirim.

Bir Cevap Yazın

Aşağıya bilgilerinizi girin veya oturum açmak için bir simgeye tıklayın:

WordPress.com Logosu

WordPress.com hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Google+ fotoğrafı

Google+ hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Twitter resmi

Twitter hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Facebook fotoğrafı

Facebook hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Connecting to %s