Metin Içerisinden Tarihleri Ayırma


Hücrede cümle içerisinde geçen tarihleri yan hücreye çıkaralım, içerisinde tarih olmayan hücreler için ise “Tarih yok” uyarısı versin.

tarih_ayir

Öncelikle tüm metinlere baktığımızda ortak olan tarihlerin slash(/) işareti ile ayrılmış olması. Metin içerisinde bu işarete ulaşabilirsem 2 karakter öncesi itibariyle tarihleri almaya başlayabiliriz.

Öyleyse bu problemin çözümünde aşağıdaki fonksiyonlardan yararlanacağız.

  • / (slash) işaretinin hücre içerisindeki yerini bulmak için

 MBUL(bul_metin;metin;[baslangıc_sayısı])

 SEARCH(find_text; within_text;[start_num])

  • işareti bulduktan sonra tarihi metin içerisinden kesip almak için.

 PARÇAAL(metin;baslangıc_sayısı;sayı_karakterler) 

 MID(text;start_num;num_chars)

formul:

=EĞER(EHATALIYSA(PARÇAAL(A2;MBUL(“/”;A2;1)-2;10));”Tarih Yok”;PARÇAAL(A2;MBUL(“/”;A2;1)-2;10))

ingilizce kullananlar için:

=IF(ISERROR(MID(A2;FIND(“/”;A2;1)-2;10));”Tarih Yok”;MID(A2;FIND(“/”;A2;1)-2;10))

sonuc :

Capture

excel dosyasını indirmek için tıklayınız:

download

Reklamlar

Bir Cevap Yazın

Aşağıya bilgilerinizi girin veya oturum açmak için bir simgeye tıklayın:

WordPress.com Logosu

WordPress.com hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Google+ fotoğrafı

Google+ hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Twitter resmi

Twitter hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Facebook fotoğrafı

Facebook hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Connecting to %s