En Büyük İlk 3 Sayının Ortalaması


Aşağıdaki örnekte en büyük ilk 3 sayının ortalamasını dizi (array) tanımlayarak tek formülle bulmaya çalışalım.

Dizi formülleri kullanırken formülü yazdıktan sonra enter değil  ctrl + shift+ enter demek gerekecektir.

Untitled

en_buyuk_uc

formül:

{=AVERAGE(LARGE(C2:C11;ROW(1:3)))}

{=ORTALAMA(BÜYÜK(C2:C11;SATIR(1:3)))}

sonuç:

Capture

excel dosyasını indirmek için tıklayınız:

download

Reklamlar

En Büyük İlk 3 Sayının Ortalaması” üzerine 4 yorum

  1. Merhaba,
    Dosyanızı kullanarak en küçük 3 değer ortalaması için uyarlama yaptım “ORTALAMA(KÜÇÜK(C2:C11;SATIR(1:3)))”, yalnız burada şöyle bir sorum olacak “0” hariç en küçük değerleri almak için nasıl bir uyarlama yapmak gerekir?

    Teşekkürler..

    • Merhaba,
      Aşağıdaki formülü kullanabilirsiniz,

      {=ORTALAMA(KÜÇÜK(C2:C11;EĞERSAY(C2:C11;0)+SATIR(1:3)))}

      EĞERSAY koyarak en küçük değer olan 0 sayısını bulduk böylece KÜÇÜK fonksiyonu ile n. küçük değer dediğimiz sıfır sayısından sonraki ilk değer olmuş oldu.

      • Çok teşekkürler, bu entry başka birininin kopyala -yapıştır yaparak kullanması durumunda formül #AD? hatası veriyor ROW kısmını SATIR olarak düzeltirlerse formül çalışıyor.
        Saygılarımla…

Bir Cevap Yazın

Aşağıya bilgilerinizi girin veya oturum açmak için bir simgeye tıklayın:

WordPress.com Logosu

WordPress.com hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Google+ fotoğrafı

Google+ hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Twitter resmi

Twitter hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Facebook fotoğrafı

Facebook hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Connecting to %s