Palindromik Cümleler


Tersten ve düzden okunduğunda aynı olan kelime ve ya cümleler palindrom adını alır.

Şimdi aşağıdaki örnekteki kelime gruplarının palindrom olup olmadıklarını formül ile çözmeye çalışacağız. Burada yine dizi (array) formülleri devreye giriyor.

Untitled

Untitled

İlk olarak cümle içerisindeki boşlukları ve var ise (bizim örneğimizde yok) özel karakterleri kaldıralım.

Capture

Şimdi C3 hücresindeki formülü inceleyelim:

{=EĞER(TOPLA.ÇARPIM((PARÇAAL(B3;SATIR(KAYDIR($H$1;0;0;UZUNLUK(B3);1));1)=PARÇAAL(B3;1+UZUNLUK(B3)-SATIR(KAYDIR($H$1;0;0;UZUNLUK(B3);1));1))*1)=UZUNLUK(B3);”PALINDROM”;”PALINDROM DEGİL”)}

{=IF(SUMPRODUCT((MID(B3;ROW(OFFSET($H$1;0;0;LEN(B3);1));1)=MID(B3;1+LEN(B3)-ROW(OFFSET($H$1;0;0;LEN(B3);1));1))*1)=LEN(B3);”PALINDROM”;”PALINDROM DEGİL”)}

SATIR(KAYDIR($H$1;0;0;UZUNLUK(B3);1));1) formülün en önemli bölümü burası: Burada  seçilen herhangi bir hücreyi (biz H1 seçtik siz istenilen başka bir hücre seçebilirsiniz, önemli olan satır numarasının 1 olması) kelimenin uzunluğu kadar bir alt satıra kaydırdık ve her bir satırın satır numarasını aldık. 

Örneğin “neden” kelimesi için H1 hücresini 5 defa kaydırdığımızda dizi formülü yardımıyla {1,2,3,4,5} şeklinde 5 adet satır numarası elde ediyoruz.

Bu satır numaraları kadar kelimeden parça alıp (baştan sona), aynı şekilde tam tersi numaralarla parçaaldığımızda {5,4,3,2,1} (sondan başa) bu iki sonucun birbirine eşit olup olmadığını kontrol ediyoruz.

excel dosyasını indirmek için tıklayınız:

download

Reklamlar

Bir Cevap Yazın

Aşağıya bilgilerinizi girin veya oturum açmak için bir simgeye tıklayın:

WordPress.com Logosu

WordPress.com hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Google+ fotoğrafı

Google+ hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Twitter resmi

Twitter hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Facebook fotoğrafı

Facebook hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Connecting to %s