Ehatalıysa (Iserror), Eğerhata (Iferror) Fonksiyonları


Formül Sonucu #YOK, #SAYI/O!, #DEĞER!, #BAŞV! gibi hatalar döndüren hücrelerin yerine istediğimiz değerleri yazalım.

Çeşitli formüller sonucu #YOK, #SAYI/0!, #DEĞER!, #BAŞV! gibi sonuçlar dönen hücrelere bu hata metinleri yerine istediğimiz başka bir değeri nasıl getireceğimizi gösterelim. Burada hücre hata değeri döndürüp döndürmedigini denetleyen EHATALIYSA / ISERROR ya da EĞERHATA / IFERROR fonksiyonlarından birini kullanacağız.

EĞERHATA / IFERROR

EĞERHATA (değer, eğer_hataysa_değer)

IFERROR(value, value_if_error)

değer : Girilen değerin #YOK, #SAYI/O!, #DEĞER!, #BAŞV! gibi hatalar içerip içermediğini denetler

eğer_hataysa_değer) : Değer hata iceriyorsa yerine yapilacak islem ya da gosterilecek değer girilir.

Capture

*Simdi hata değerleri yerine 0 (sıfır) yazdıralım:

Capture

*D2 hücresindeki formülu okuyalım:

=IFERROR(A2/B2,0) = A2/B2 işlemi hata veriyor ise 0 yaz, vermiyorsa A2/B2 sonucunu yaz.

EHATALIYSA / ISERROR

Ehatalıysa formülü hücrenin #YOK, #SAYI/O!, #DEĞER!, #BAŞV! gibi hatalar içerip içermediğini denetler, eğer içeriyorsa “Doğru”, içermiyorsa “Yanlış” değerini verir. Sonrasında bir işlem yaptırmaz.

Capture

EĞERHATA fonksiyonundan farkı EHATALIYSA Fonksiyonu sadece hata denetimi yapar. EĞERHATA gibi kullanmak isteniyorsa basına extra bir eğer formülü girilmelidir.

=EĞER(EHATALIYSA(formül);””;formül)

=IF(ISERROR(function);””;function)

‘yani hücreye girdiğimiz formül hatalı sonuç döndürüyorsa boş bırak, döndürmüyorsa formül sonucunu ver. Burada boş bırakmak yerine istediğimiz başka bir değer girebilirdik.

Capture

EĞERHATA var iken neden EHATALIYSA’yı if fonksiyonu ile kullanayım?

1- 2007 den onceki surumlerde EĞERHATA fonksiyonu yok. Ehataliysa ve if ile aynı kullanımı formüluze etmek gerekiyor.

2- EĞERHATA hata yok ise ilk değeri yazar, EHATALIYSA da hata yok ise 3. bir değeri yazdırabiliriz.

Not: DÜŞEYARA KAÇINCI İNDİS gibi fonksiyonların sonuclarini alırken hata donen hücreleri sıfır ya da boş getirmek için sıkca kullanılacak formüllerdir.

excel dosyasını indirmek için tıklayınız:

download

Reklamlar

Ehatalıysa (Iserror), Eğerhata (Iferror) Fonksiyonları” üzerine 3 yorum

Bir Cevap Yazın

Aşağıya bilgilerinizi girin veya oturum açmak için bir simgeye tıklayın:

WordPress.com Logosu

WordPress.com hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Google fotoğrafı

Google hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Twitter resmi

Twitter hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Facebook fotoğrafı

Facebook hesabınızı kullanarak yorum yapıyorsunuz. Çıkış  Yap /  Değiştir )

Connecting to %s