Dolu Hücreleri Say


BAĞ_DEĞ_DOLU_SAY /COUNTA fonksiyonu

BAĞ_DEĞ_DOLU_SAY /COUNTA fonksiyonu hücre ya da hücre aralığındaki dolu hücrelerin sayısını verir. Sayı, metin, hata, özel karakter, boş metinler (“”), mantıksal değerler (DOĞRU/YANLIŞ) hepsini sayar, yalnızca boş hücreleri saymaz.

BAĞ_DEĞ_DOLU_SAY(değer1, [değer2], …)

COUNTA(value1, [value2], …)

Devamı »

Reklamlar

İki ayrı listedeki aynı değerler


Elimizde sayı ya da metin şeklinde değerler içeren iki farklı liste olsun. Öncelikle iki listede tekrar eden değerler olup olmadığına hızlıca bakalım, ikinci adımda ise bu iki listede ortak geçen değer adedine ulaşmaya çalışalım.

duplicatevalues4

1.adım: İki tabloyu seçili hale getirdikten sonra Menu’de Giriş/ Home, Koşullu Biçimlendirme/Conditional Formatting komutuna tıklayalım. Açılan listeden Yinelenen Değerleri/Duplicate Values seçelim.İstediğimiz hücre formatını seçtikten sonra ok’e basalım.

duplicatevalues1

duplicatevalues
duplicatevalues2
duplicatevalues3

2.adım: Şimdi formülle iki ayrı listede kaç adet yinelenen/ortak değer var bulmaya çalışalım.

duplicatevalues5

formül:

{=SUM(COUNTIF(A2:A12;OFFSET(C2;0;0;COUNTA(C2:C12);1)))}

{=TOPLA(EĞERSAY(A2:A12;KAYDIR(C2;0;0;BAĞ_DEĞ_DOLU_SAY(C2:C12);1)))}

Not: Bu bir dizi formülü olduğu için formülü yazdıktan sonra ctrl+shift+enter a basmayı unutmayınız.

excel dosyasını indirmek için tıklayınız:

farkli_listeler_ayni_degerler

 

Kaydır (Offset) ile Bağ_Değ_Dolu_Say (Counta) Fonksiyonları


KAYDIR (OFFSET) FONKSİYONU VE BAĞ_DEĞ_DOLU_SAY (COUNTA) KULLANARAK DİNAMİK ALAN OLUŞTURMAK

Öncelikle KAYDIR( OFFSET) fonksiyonun işlevinden bahsedelim. Bu fonksiyon Basit olarak referans olarak verdiğimiz hücreden yine bizim belirlediğimiz satır ve sütun uzaktaki hücrenin değerini döndürür.

KAYDIR(başv; satırlar; sütunlar; [yükseklik]; [genişlik])

OFFSET(reference,rows,cols,[height],[width])

Devamı »