Düşeyara ile aranan değerin max/min karşılığını getir


Sadece Duseyara/Vlookup kullanarak aranan degerin tablodaki max. karsiligini getirmek maalesef mumkun degildir. Bu konuda boyle durumlarda kullanabilecegimiz alternatif formulleri ve ipuclarini gorecegiz.

Asagidaki tabloda her bir bisiklet cesidinin max satis adetlerini sari, min satis adetlerini ise kirmizi ile belirttim. Ana tablo uzerindeki max/min satislari isteyen tabloyu dolduralim.

vlookup

Devamı »

Reklamlar

Kaçıncı (Match), Indis (Index) Fonksiyonlar


  • İNDİS () / INDEX() fonksiyonu ilgili dizi, hücre aralığındaki verilen satır ve sütun numarasındaki değeri döndürür.

İNDİS(dizi;satırsayısı;sütunsayısı) => İNDİS(tablom; kaçıncı satır; kaçıncı sütun)

INDEX(array, row_num, [col_num])

Aşağıdaki örnekteki çeşitli değerleri İNDİS / INDEX fonksiyonuyla getirelim:

index2

Devamı »

Çok Kriterli Düşeyara


 

coklu_dus

Tek kritere gore arama yaptığımızda Düşeyara formülünün kullanımını detaylı olarak işlemiştik. Peki aranan değerimiz 2 ve ya daha fazla ise düşeyara formülünü nasıl kullanacağız?

Bu şekildeki durumları nasıl çözebileceğimizi aynı örnek üzerinden kolaydan zora doğru giden 3 farklı yöntem ile anlatmaya çalışacağım.

Elimizde ürün isimleri ve yılların olduğu bir data tablomuz var. Yandaki secimli listeden secilen ürunun yine secilen yıldaki satısını getirelim.

Devamı »

Dolaylı (Indirect) Fonksiyonu


Fonksiyonu formül içerisine verilen hücre başvurusunun değerini döndürür.

DOLAYLI(başv_metni,[a1])

INDIRECT(ref_text, a1)

başv_metni (ref_text) : Başvurulan hücre
a1: başvurulan hücrenin hücre stili, bu kısım DOĞRU ve YANLIŞ değerini alır.

1.Dolaylı(Indirect) Fonksiyonu ile hücre başvurusu örnekleri : 

Microsoft Excel - dolayli_indirect_fonksiyonu1

 

Formülleri okuyalım:

17 =DOLAYLI(“A3”) direk bir hücre içindeki değeri döndürmek istiyor isek hücre adresi çift tırnak içinde verilmeli.
24 =DOLAYLI(“B”&D4) D4 deki değer 5; ile işaretiyle bunu B sütunuyla birleştirip B5 hücresindeki değeri döndürdü.
15 =DOLAYLI(ADRES(3;3)) Adres(3;3) bize $C$3 şeklinde döner, C3 hücresindeki değer bize sonuç olarak döndü.
9 =DOLAYLI(“R2C4”;YANLIŞ) r1c1 stilini kullandık 2.satır4. sütundaki veriyi getirdik,
75 =TOPLA(DOLAYLI(“A6:E6”)) fonksiyon içerisinde alan tanımladık ve bu alandaki verileri topladık.
6 =DOLAYLI(A2) A2 hücresinin içine B8 hücre değerini verdik. A2 yi tırnak içinde yazsaydım bize sonuç olarak B8 i verecekti, tırnak içinde yazmadık içerisindeki hücrenin başvurusunu verdi.
11 =DOLAYLI(“C”&2) C sütunu ile 2. satırı birleştirdik C2 deki değeri aldık.
22 =DOLAYLI(“E”&SATIR()-15) bulunduğumuz satır numarası 17-15 = 2 E2 deki değeri aldık.

NOT: Başvuru olarak R1C1 (row1,column1) şeklinde giriş yapılırsa a1 değerine “YANLIŞ” girilmelidir. A1 şeklindeki başvurular için bu kısım default olarak “DOĞRU” gelir elle girmeye gerek yoktur.

Devamı »